rules 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8. # Uncomment this to turn on verbose mode.
  9. #export DH_VERBOSE=1
  10. # These are used for cross-compiling and for saving the configure script
  11. # from having to guess our platform (since we know it already)
  12. DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
  13. DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
  14. CFLAGS = -Wall -g
  15. ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
  16. CFLAGS += -O0
  17. else
  18. CFLAGS += -O2
  19. endif
  20. config.status: configure
  21. dh_testdir
  22. # Add here commands to configure the package.
  23. ifneq "$(wildcard /usr/share/misc/config.sub)" ""
  24. cp -f /usr/share/misc/config.sub config.sub
  25. endif
  26. ifneq "$(wildcard /usr/share/misc/config.guess)" ""
  27. cp -f /usr/share/misc/config.guess config.guess
  28. endif
  29. ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
  30. configure:
  31. autoconf
  32. build: build-stamp
  33. build-stamp: config.status
  34. dh_testdir
  35. # Add here commands to compile the package.
  36. $(MAKE)
  37. #docbook-to-man debian/softflowd.sgml > softflowd.1
  38. touch $@
  39. clean:
  40. dh_testdir
  41. dh_testroot
  42. rm -f build-stamp
  43. # Add here commands to clean up after the build process.
  44. [ ! -f Makefile ] || $(MAKE) distclean
  45. rm -f config.sub config.guess
  46. dh_clean
  47. install: build
  48. dh_testdir
  49. dh_testroot
  50. dh_clean -k
  51. dh_installdirs
  52. # Add here commands to install the package into debian/softflowd.
  53. $(MAKE) prefix=$(CURDIR)/debian/softflowd/usr install
  54. # Build architecture-independent files here.
  55. binary-indep: build install
  56. # We have nothing to do by default.
  57. # Build architecture-dependent files here.
  58. binary-arch: build install
  59. dh_testdir
  60. dh_testroot
  61. dh_installchangelogs ChangeLog
  62. dh_installdocs
  63. dh_installexamples
  64. # dh_install
  65. # dh_installmenu
  66. dh_installdebconf
  67. # dh_installlogrotate
  68. # dh_installemacsen
  69. # dh_installpam
  70. # dh_installmime
  71. # dh_python
  72. dh_installinit
  73. # dh_installcron
  74. # dh_installinfo
  75. dh_installman
  76. dh_link
  77. dh_strip
  78. dh_compress
  79. dh_fixperms
  80. # dh_perl
  81. # dh_makeshlibs
  82. dh_installdeb
  83. dh_shlibdeps
  84. dh_gencontrol
  85. dh_md5sums
  86. dh_builddeb
  87. binary: binary-indep binary-arch
  88. .PHONY: build clean binary-indep binary-arch binary install