cherry-pick.softflowd-0.9.9-22-ge6d29a1.fix-some-bugs.patch 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. Subject: [ Add option "-a" for reading pcap file and ] fix some bugs
  2. Origin: softflowd-0.9.9-22-ge6d29a1 <https://github.com/irino/softflowd/commit/e6d29a1>
  3. Upstream-Author: Hitoshi Irino <irino@sfc.wide.ad.jp>
  4. Date: Sun May 26 23:00:41 2019 +0900
  5. Comment: Fixes a regression introduced in buster: The flow aggregation
  6. is broken, causing a new flow to generated for virtually each packet.
  7. If the daemon sees a lot of traffic, the flow table might overflow,
  8. resulting in forced expiration and 100% CPU usage.
  9. .
  10. Thanks Johanna Jerzembeck for reporting and testing.
  11. - fix flow_compare for comparing vlan and ether
  12. [ - fix missing sequence in netflow v9 ]
  13. --- a/softflowd.c
  14. +++ b/softflowd.c
  15. @@ -55,6 +55,8 @@
  16. static int verbose_flag = 0; /* Debugging flag */
  17. static u_int16_t if_index = 0; /* "manual" interface index */
  18. +static int track_level;
  19. +
  20. /* Signal handler flags */
  21. static volatile sig_atomic_t graceful_shutdown_request = 0;
  22. @@ -144,15 +146,21 @@
  23. {
  24. /* Be careful to avoid signed vs unsigned issues here */
  25. int r;
  26. + if (track_level == TRACK_FULL_VLAN || track_level == TRACK_FULL_VLAN_ETHER) {
  27. + if (a->vlanid[0] != b->vlanid[0])
  28. + return (a->vlanid[0] > b->vlanid[0] ? 1 : -1);
  29. +
  30. + if (a->vlanid[1] != b->vlanid[1])
  31. + return (a->vlanid[1] > b->vlanid[1] ? 1 : -1);
  32. + }
  33. - if (a->vlanid != b->vlanid)
  34. - return (a->vlanid > b->vlanid ? 1 : -1);
  35. -
  36. + if (track_level == TRACK_FULL_VLAN_ETHER) {
  37. if ((r = memcmp(&a->ethermac[0], &b->ethermac[0], 6)) != 0)
  38. return (r > 0 ? 1 : -1);
  39. if ((r = memcmp(&a->ethermac[1], &b->ethermac[1], 6)) != 0)
  40. return (r > 0 ? 1 : -1);
  41. + }
  42. if (a->af != b->af)
  43. return (a->af > b->af ? 1 : -1);
  44. @@ -1526,7 +1534,7 @@
  45. ft->param.max_flows = DEFAULT_MAX_FLOWS;
  46. - ft->param.track_level = TRACK_FULL;
  47. + track_level = ft->param.track_level = TRACK_FULL;
  48. ft->param.tcp_timeout = DEFAULT_TCP_TIMEOUT;
  49. ft->param.tcp_rst_timeout = DEFAULT_TCP_RST_TIMEOUT;
  50. @@ -1882,6 +1890,7 @@
  51. usage();
  52. exit(1);
  53. }
  54. + track_level = flowtrack.param.track_level;
  55. break;
  56. case 'L':
  57. hoplimit = atoi(optarg);