123456789101112131415161718192021222324252627282930313233343536 |
- Subject: Use asciidoctor to build the manpages
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Date: 2018-08-11
- Bug: https://github.com/latchset/tang/issues/32
- --- a/meson.build
- +++ b/meson.build
- @@ -46,7 +46,7 @@
- )
-
- jose = dependency('jose', version: '>=8')
- -a2x = find_program('a2x', required: false)
- +asciidoctor = find_program('asciidoctor', required: false)
- compiler = meson.get_compiler('c')
- if not compiler.has_header('http_parser.h')
- error('http-parser devel files not found.')
- @@ -69,16 +69,16 @@
- install_data(units, install_dir: systemunitdir)
- install_data(licenses, install_dir: licensedir)
-
- -if a2x.found()
- +if asciidoctor.found()
- foreach m : mans
- custom_target(m.split('/')[-1], input: m + '.adoc', output: m.split('/')[-1],
- - command: [a2x, '-f', 'manpage', '-D', meson.current_build_dir(), '@INPUT@'],
- + command: [asciidoctor, '--attribute', 'reproducible', '--backend=manpage', '-D', meson.current_build_dir(), '@INPUT@'],
- install_dir: join_paths(get_option('mandir'), 'man' + m.split('.')[-1]),
- install: true
- )
- endforeach
- else
- - warning('Will not build man pages due to missing a2x (asciidoc) dependency!')
- + warning('Will not build man pages due to missing asciidoctor (asciidoc) dependency!')
- endif
-
- # vim:set ts=2 sw=2 et:
|