run-testsuite 782 B

12345678910111213141516171819202122
  1. #!/bin/sh
  2. set -e
  3. cd tests
  4. export PATH="$PATH:/usr/libexec:/usr/lib/$(dpkg-architecture --query=DEB_HOST_GNU_TYPE 2>/dev/null)"
  5. for f in $(find . -type f -executable | sort) ; do
  6. echo "I: Preparing test $f"
  7. # replace socket activation with socat
  8. if [ "$f" = './adv' ] ; then
  9. sed -i -e 's;\$SD_ACTIVATE -l "127.0.0.1:\$PORT" -a \$VALGRIND tangd \$TMP/cache;socat TCP-LISTEN:$PORT,bind=127.0.0.1,fork "EXEC:tangd $TMP/cache";' $f
  10. elif [ "$f" = './rec' ] ; then
  11. sed -i -e 's;\$SD_ACTIVATE -l 127.0.0.1:\$port -a \$VALGRIND tangd \$TMP/cache;socat TCP-LISTEN:$port,bind=127.0.0.1,fork "EXEC:tangd $TMP/cache";' $f
  12. fi
  13. echo "I: Running test $f"
  14. # test are very noisy, keep them silent as long as they pass
  15. chronic "$f" || :
  16. done
  17. exit 0