local.avoid-keygen-race.patch 778 B

12345678910111213141516171819202122232425262728
  1. Description: Avoid race condition between keygen and update, resulting in "Key derivation key not available!"
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Bug: https://github.com/latchset/tang/issues/52
  4. Bug-Debian: https://bugs.debian.org/975343
  5. Last-Update: 2021-01-25
  6. --- a/units/tangd-update.service.in
  7. +++ b/units/tangd-update.service.in
  8. @@ -1,5 +1,7 @@
  9. [Unit]
  10. Description=Tang Server key update script
  11. +Requires=tangd-keygen.service
  12. +After=tangd-keygen.service
  13. [Service]
  14. Type=oneshot
  15. --- a/units/tangd.socket.in
  16. +++ b/units/tangd.socket.in
  17. @@ -1,9 +1,7 @@
  18. [Unit]
  19. Description=Tang Server socket
  20. -Requires=tangd-keygen.service
  21. Requires=tangd-update.service
  22. Requires=tangd-update.path
  23. -After=tangd-keygen.service
  24. After=tangd-update.service
  25. [Socket]