123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106 |
- #!/usr/bin/make -f
- # Sample debian/rules that uses debhelper.
- # GNU copyright 1997 to 1999 by Joey Hess.
- # Uncomment this to turn on verbose mode.
- #export DH_VERBOSE=1
- # This is the debhelper compatibility version to use.
- export DH_COMPAT=3
- # These are used for cross-compiling and for saving the configure script
- # from having to guess our platform (since we know it already)
- DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
- DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
- ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
- endif
- ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
- endif
- config.status: configure
- dh_testdir
- # Add here commands to configure the package.
- ./configure --host=$(DEB_HOST_GNU_TYPE) \
- --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info
- build: build-stamp
- build-stamp: config.status
- dh_testdir
- # Add here commands to compile the package.
- $(MAKE)
- #/usr/bin/docbook-to-man debian/tcpreplay.sgml > tcpreplay.1
- touch build-stamp
- clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- # Add here commands to clean up after the build process.
- -$(MAKE) distclean
- -test -r /usr/share/misc/config.sub && \
- cp -f /usr/share/misc/config.sub config.sub
- -test -r /usr/share/misc/config.guess && \
- cp -f /usr/share/misc/config.guess config.guess
- dh_clean
- install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- # Add here commands to install the package into debian/tcpreplay.
- $(MAKE) install prefix=$(CURDIR)/debian/tcpreplay/usr
- rm $(CURDIR)/debian/tcpreplay/usr/bin/man2html
- # Build architecture-independent files here.
- binary-indep: build install
- # We have nothing to do by default.
- # Build architecture-dependent files here.
- binary-arch: build install
- dh_testdir
- dh_testroot
- # dh_installdebconf
- dh_installdocs
- # dh_installexamples
- # dh_installmenu
- # dh_installlogrotate
- # dh_installemacsen
- # dh_installpam
- # dh_installmime
- # dh_installinit
- dh_installcron
- dh_installman
- # dh_installinfo
- # dh_undocumented
- dh_installchangelogs docs/CHANGELOG
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- # dh_makeshlibs
- dh_installdeb
- # dh_perl
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary install
|