configure-pcap.patch 1.4 KB

1234567891011121314151617181920212223242526272829303132333435
  1. Author: gregor herrmann <gregoa@debian.org>
  2. Date: 2012-03-14 18:44:39 +0100
  3. Fix configure to find libpcap
  4. --- tcpreplay-3.4.4/configure.ac.orig 2010-04-05 02:58:05.000000000 +0200
  5. +++ tcpreplay-3.4.4/configure.ac 2012-07-06 23:27:29.000000000 +0200
  6. @@ -39,6 +39,7 @@
  7. AC_SUBST(host)
  8. AC_SUBST(build)
  9. AC_SUBST(target)
  10. +MULTIARCH=$(dpkg-architecture -qDEB_HOST_MULTIARCH)
  11. have_cygwin=no
  12. AC_MSG_CHECKING([for cygwin development environment])
  13. @@ -355,6 +356,8 @@
  14. LPCAPLIB="-L${testdir}/lib64 -lpcap"
  15. elif test -f "${testdir}/lib/libpcap${shrext_cmds}" ; then
  16. LPCAPLIB="-L${testdir}/lib -lpcap"
  17. + elif test -f "${testdir}/lib/$MULTIARCH/libpcap${shrext_cmds}" ; then
  18. + LPCAPLIB="-L${testdir}/lib/$MULTIARCH/lib -lpcap"
  19. else
  20. AC_ERROR([Unable to find libpcap in ${testdir}])
  21. fi
  22. @@ -364,6 +367,9 @@
  23. LPCAPLIB="${testdir}/lib/libpcap.${libext}"
  24. elif test -f "${testdir}/lib/libwpcap.${libext}" ; then
  25. LPCAPLIB="${testdir}/lib/libwpcap.${libext}"
  26. + elif test -f "${testdir}/lib/$MULTIARCH/libpcap.${libext}" ; then
  27. + LPCAPLIB="${testdir}/lib/$MULTIARCH/libpcap.${libext}"
  28. +
  29. AC_DEFINE([HAVE_WINPCAP], [1], [Do we have WinPcap?])
  30. else
  31. AC_ERROR([Unable to find matching library for header file in ${testdir}])