12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394 |
- #!/usr/bin/make -f
- # Uncomment this to turn on verbose mode.
- #export DH_VERBOSE=1
- DEB_HOST_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
- DEB_BUILD_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
- ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
- confflags= --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
- else
- confflags= --build $(DEB_BUILD_GNU_TYPE)
- endif
- CFLAGS = `dpkg-buildflags --get CFLAGS`
- CFLAGS += -g -Wall
- CXXFLAGS = `dpkg-buildflags --get CXXFLAGS` -g -Wall
- LDFLAGS = `dpkg-buildflags --get LDFLAGS`
- CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
- configure-stamp:
- dh_testdir
- dh_autoreconf
- # Add here commands to configure the package.
- CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) \
- --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr \
- --enable-debug \
- --enable-dynamic-link \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info
- touch configure-stamp
- build: build-arch build-indep
- build-arch: build-stamp
- build-indep: build-stamp
- build-stamp: configure-stamp
- dh_testdir
- # Add here commands to compile the package.
- $(MAKE)
- #/usr/bin/docbook-to-man debian/tcpreplay.sgml > tcpreplay.1
- touch build-stamp
- clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
- dh_autoreconf_clean
- dh_clean
- install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- # Add here commands to install the package into debian/tcpreplay.
- $(MAKE) install prefix=$(CURDIR)/debian/tcpreplay/usr
- # Build architecture-independent files here.
- binary-indep: build install
- # We have nothing to do by default.
- # Build architecture-dependent files here.
- binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installcron
- dh_installman
- dh_installchangelogs docs/CHANGELOG
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary install configure
|