rules 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. #!/usr/bin/make -f
  2. # Sample debian/rules that uses debhelper.
  3. # This file is public domain software, originally written by Joey Hess.
  4. # Uncomment this to turn on verbose mode.
  5. #export DH_VERBOSE=1
  6. # This is the debhelper compatibility version to use.
  7. export DH_COMPAT=2
  8. build: build-stamp
  9. build-stamp:
  10. dh_testdir
  11. # Add here commands to compile the package.
  12. ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
  13. $(MAKE)
  14. touch build-stamp
  15. clean:
  16. dh_testdir
  17. dh_testroot
  18. rm -f build-stamp
  19. # Add here commands to clean up after the build process.
  20. -$(MAKE) clean
  21. -$(MAKE) distclean
  22. dh_clean
  23. install: build
  24. dh_testdir
  25. dh_testroot
  26. dh_clean -k
  27. dh_installdirs
  28. # Add here commands to install the package into debian/<packagename>
  29. $(MAKE) PREFIX=`pwd`/debian/`dh_listpackages`/usr install
  30. # Build architecture-independent files here.
  31. binary-indep: build install
  32. # We have nothing to do by default.
  33. # Build architecture-dependent files here.
  34. binary-arch: build install
  35. dh_testversion 2
  36. dh_testdir
  37. dh_testroot
  38. # dh_installdebconf
  39. dh_installdocs
  40. dh_installexamples
  41. dh_installmenu
  42. # dh_installlogrotate
  43. # dh_installemacsen
  44. # dh_installpam
  45. # dh_installmime
  46. # dh_installinit
  47. dh_installcron
  48. dh_installmanpages
  49. dh_installinfo
  50. # dh_undocumented
  51. dh_installchangelogs CHANGES
  52. dh_link
  53. dh_strip
  54. dh_compress
  55. dh_fixperms
  56. # You may want to make some executables suid here.
  57. dh_suidregister
  58. # dh_makeshlibs
  59. dh_installdeb
  60. # dh_perl
  61. dh_shlibdeps
  62. dh_gencontrol
  63. dh_md5sums
  64. dh_builddeb
  65. binary: binary-indep binary-arch
  66. .PHONY: build clean binary-indep binary-arch binary install