changelog 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403
  1. tcpreplay (4.2.6-1) unstable; urgency=medium
  2. * Handle frames with a capture length bigger than the buffer
  3. -- Christoph Biedl <debian.axhn@manchmal.in-ulm.de> Tue, 01 Aug 2017 22:21:48 +0000
  4. tcpreplay (4.2.6-1~exp1) experimental; urgency=medium
  5. * Upload to experimental
  6. * New upstream version 4.2.6. Fixes build error on sparc64
  7. -- Christoph Biedl <debian.axhn@manchmal.in-ulm.de> Tue, 16 May 2017 17:48:35 +0000
  8. tcpreplay (4.2.5-1) unstable; urgency=medium
  9. * New upstream version 4.2.5. Also fixes test for architectures
  10. where unaligned memory access is not acceptable. Closes: #861539
  11. -- Christoph Biedl <debian.axhn@manchmal.in-ulm.de> Tue, 09 May 2017 01:10:08 +0200
  12. tcpreplay (4.2.4-1) unstable; urgency=medium
  13. * New maintainer. Thanks Noël Köthe for many years of maintaining and
  14. also for handing over.
  15. * New upstream version 4.2.4. Closes: #792248
  16. -- Christoph Biedl <debian.axhn@manchmal.in-ulm.de> Sat, 29 Apr 2017 11:33:16 +0200
  17. tcpreplay (3.4.4-3) unstable; urgency=medium
  18. * extend the long description with the included executables to
  19. make them searchable with apt. closes: #796691
  20. * added enforce-maxpacket.patch. Thanks Christoph. closes: #829350
  21. * debian/compat moved to debhelper 9
  22. * debian/control raised Standards-Version no changes needed
  23. * debian/rules added hardening to the build
  24. -- Noël Köthe <noel@debian.org> Sat, 02 Jul 2016 20:02:26 +0200
  25. tcpreplay (3.4.4-2) unstable; urgency=low
  26. * debian/control fixed lintian error
  27. depends-on-build-essential-package-without-using-version and
  28. lintian warning debhelper-but-no-misc-depends
  29. -- Noël Köthe <noel@debian.org> Sat, 07 Jul 2012 16:19:30 +0200
  30. tcpreplay (3.4.4-1) unstable; urgency=low
  31. * new upstream release 2010-04-04 closes: Bug#634538
  32. Thanks gregor and Simon for the patch I changed a bit to
  33. get it build again
  34. * debian/control updated Standards-Version, no changes needed
  35. * added missing --enable-debug for the -d option
  36. closes: Bug#651073
  37. * debian/copyright updated year and email from docs/LICENSE
  38. -- Noël Köthe <noel@debian.org> Fri, 06 Jul 2012 02:03:04 +0200
  39. tcpreplay (3.4.3-2) unstable; urgency=low
  40. * debian/compat raised to 5 like the dependency in 3.4.3-1
  41. -- Noèl Köthe <noel@debian.org> Sat, 25 Jul 2009 20:02:43 +0200
  42. tcpreplay (3.4.3-1) unstable; urgency=low
  43. * new release from 2009-06-25
  44. * debian/control
  45. - removed URLs in description because we have Homepage:
  46. - updated Standards-Version (no changes needed)
  47. - raised Build-Depends version of debhelpter to 5
  48. -- Noèl Köthe <noel@debian.org> Fri, 26 Jun 2009 10:25:15 +0200
  49. tcpreplay (3.4.1-1) unstable; urgency=low
  50. * new upstream release from 2009-02-21
  51. * updated Standards-Version
  52. -- Noèl Köthe <noel@debian.org> Sat, 21 Feb 2009 14:37:11 +0100
  53. tcpreplay (3.3.2-1) unstable; urgency=low
  54. * new upstream release from 2008-06-20
  55. (closes: Bug#505550)
  56. -- Noèl Köthe <noel@debian.org> Sat, 15 Nov 2008 22:57:38 +0100
  57. tcpreplay (3.3.1-1) unstable; urgency=low
  58. * new upstream release from 2008-05-17
  59. * debin/control added Homepage:
  60. -- Noèl Köthe <noel@debian.org> Thu, 22 May 2008 18:05:19 +0200
  61. tcpreplay (3.2.4-1) unstable; urgency=low
  62. * new upstream release from 2008-01-16
  63. * remove empty dirs from package /usr/sbin
  64. -- Noèl Köthe <noel@debian.org> Sun, 20 Jan 2008 12:11:17 +0100
  65. tcpreplay (3.2.3-1) unstable; urgency=low
  66. * new upstream release from 2007-11-01
  67. - fixes double free if tcpreplay -N is launched as normal user
  68. (closes: Bug#442132)
  69. * correcting debian-rules-ignores-make-clean-error correct
  70. (closes: Bug#448259)
  71. * fixed sourceforge watch file
  72. (closes: Bug#450062)
  73. -- Noèl Köthe <noel@debian.org> Sun, 11 Nov 2007 13:18:21 +0100
  74. tcpreplay (3.2.1-1) unstable; urgency=low
  75. * new upstream release from 2007-10-25
  76. * correcting debian-rules-ignores-make-clean-error
  77. -- Noèl Köthe <noel@debian.org> Fri, 26 Oct 2007 17:54:14 +0200
  78. tcpreplay (3.2.0-1) unstable; urgency=low
  79. * new upstream release from 2007-08-27
  80. -- Noèl Köthe <noel@debian.org> Mon, 27 Aug 2007 18:21:31 +0200
  81. tcpreplay (3.1.1-1) unstable; urgency=low
  82. * new upstream release from 2007-07-19
  83. -- Noèl Köthe <noel@debian.org> Sun, 22 Jul 2007 13:03:44 +0200
  84. tcpreplay (3.0.1-1) unstable; urgency=low
  85. * new upstream release from 2007-05-01
  86. - fixed gcc 4.3 "inline" change (closes: Bug#416857)
  87. * added build-dep autotools-dev to update config.sub+.guess
  88. -- Noèl Köthe <noel@debian.org> Sun, 06 May 2007 11:40:47 +0200
  89. tcpreplay (2.99+3.0.rc1-1) unstable; urgency=low
  90. * new upstream release from 2007-04-15
  91. - upstream removed the docs/*.pdf
  92. * dlt problem should be fixed since beta13
  93. http://tcpreplay.synfin.net/trac/ticket/82
  94. (closes: Bug#414613)
  95. -- Noèl Köthe <noel@debian.org> Sun, 15 Apr 2007 14:10:24 +0200
  96. tcpreplay (2.99+3.0.beta11-4) unstable; urgency=low
  97. * rebuilt to built against libopts25
  98. (closes: Bug#409056)
  99. -- Noèl Köthe <noel@debian.org> Fri, 02 Feb 2007 22:51:37 +0100
  100. tcpreplay (2.99+3.0.beta11-3) unstable; urgency=low
  101. * fix compile error (newpkt undeclared, post_args)
  102. http://tcpreplay.synfin.net/trac/changeset/1589 and
  103. http://tcpreplay.synfin.net/trac/changeset/1590
  104. (closes: Bug#387670)
  105. -- Noèl Köthe <noel@debian.org> Sat, 16 Sep 2006 15:17:17 +0200
  106. tcpreplay (2.99+3.0.beta11-2) unstable; urgency=low
  107. * fix compile error (no field ipbuff)
  108. http://tcpreplay.synfin.net/trac/changeset/1587
  109. (closes: Bug#379657)
  110. * removing build-deps libnids-dev, libnet1-dev
  111. (not needed anymore)
  112. -- Noèl Köthe <noel@debian.org> Fri, 15 Sep 2006 15:08:17 +0200
  113. tcpreplay (2.99+3.0.beta11-1) unstable; urgency=low
  114. * new upstream from 2006-08-08
  115. -- Noèl Köthe <noel@debian.org> Tue, 08 Aug 2006 22:01:01 +0200
  116. tcpreplay (2.99+3.0.beta9-1) unstable; urgency=low
  117. * new upstream from 2006-07-17
  118. * updated standards-version
  119. -- Noèl Köthe <noel@debian.org> Sat, 22 Jul 2006 11:34:10 +0200
  120. tcpreplay (2.99+3.0.beta7-2) unstable; urgency=low
  121. * updated homepage http://tcpreplay.synfin.net
  122. * fix conflicting types for 'speed_t'
  123. (closes: Bug#361065)
  124. -- Noèl Köthe <noel@debian.org> Mon, 10 Apr 2006 22:07:02 +0200
  125. tcpreplay (2.99+3.0.beta7-1) unstable; urgency=low
  126. * new upstream beta
  127. -- Noèl Köthe <noel@debian.org> Wed, 24 Aug 2005 18:01:46 +0200
  128. tcpreplay (2.99+3.0.beta6-4) unstable; urgency=low
  129. * change build-dep from libpcap0.9 to libpcap0.8
  130. -- Noèl Köthe <noel@debian.org> Thu, 07 Jul 2005 17:22:05 +0200
  131. tcpreplay (2.99+3.0.beta6-3) unstable; urgency=low
  132. * removed libopts* files from the package and depends on
  133. autogen/libopts25 which provides these files
  134. (closes: Bug#316950)
  135. * added libnids-dev build-dependency
  136. -- Noèl Köthe <noel@debian.org> Thu, 07 Jul 2005 17:22:05 +0200
  137. tcpreplay (2.99+3.0.beta6-2) unstable; urgency=low
  138. * remove stupid man2html in package
  139. -- Noèl Köthe <noel@debian.org> Mon, 04 Jul 2005 23:19:26 +0200
  140. tcpreplay (2.99+3.0.beta6-1) unstable; urgency=low
  141. * upgrading to the tcpreplay 3.0 tree
  142. * switch to libpcap0.9-dev
  143. * updated Standards-Version
  144. * added watch file
  145. -- Noèl Köthe <noel@debian.org> Mon, 04 Jul 2005 19:32:52 +0200
  146. tcpreplay (2.3.3-1) unstable; urgency=low
  147. * new upstream from 2005-02-10
  148. -- Noèl Köthe <noel@debian.org> Sat, 12 Feb 2005 21:18:10 +0100
  149. tcpreplay (2.3.2-1) unstable; urgency=low
  150. * new upstream from 2004-11-08
  151. -- Noèl Köthe <noel@debian.org> Mon, 08 Nov 2004 19:42:50 +0100
  152. tcpreplay (2.3.1-1) unstable; urgency=low
  153. * new upstream from 2004-09-26
  154. -- Noèl Köthe <noel@debian.org> Mon, 27 Sep 2004 21:41:47 +0200
  155. tcpreplay (2.3.0-1) unstable; urgency=low
  156. * new upstream from 2004-09-05
  157. * changed build-dep from libpcap-dev to libpcap0.8-dev
  158. -- Noèl Köthe <noel@debian.org> Mon, 13 Sep 2004 20:18:46 +0200
  159. tcpreplay (2.2.2-1) unstable; urgency=low
  160. * new upstream from 2004-06-21
  161. * the release fixes the rewrite source mac address problem
  162. (closes: Bug#253391)
  163. -- Noèl Köthe <noel@debian.org> Wed, 07 Jul 2004 18:11:21 +0200
  164. tcpreplay (2.2.0-1) unstable; urgency=low
  165. * new upstream from 2004-05-15
  166. -- Noèl Köthe <noel@debian.org> Sun, 16 May 2004 12:26:20 +0200
  167. tcpreplay (2.1.1-1) unstable; urgency=low
  168. * new upstream
  169. -- Noèl Köthe <noel@debian.org> Sun, 02 May 2004 01:19:08 +0200
  170. tcpreplay (2.0.3-1) unstable; urgency=low
  171. * new upstream
  172. -- Noèl Köthe <noel@debian.org> Thu, 25 Mar 2004 19:14:46 +0100
  173. tcpreplay (2.0.2-1) unstable; urgency=low
  174. * new upstream which fixes compile issue
  175. (closes: Bug#233062)
  176. -- Noèl Köthe <noel@debian.org> Wed, 25 Feb 2004 23:07:56 +0100
  177. tcpreplay (2.0.1-2) unstable; urgency=low
  178. * added missing tcpdump dependency
  179. (closes: Bug#232606)
  180. -- Noèl Köthe <noel@debian.org> Sat, 14 Feb 2004 11:47:21 +0100
  181. tcpreplay (2.0.1-1) unstable; urgency=low
  182. * new upstream from 2004-02-03
  183. -- Noèl Köthe <noel@debian.org> Fri, 13 Feb 2004 21:09:46 +0100
  184. tcpreplay (1.4.6-1) unstable; urgency=low
  185. * new upstream from 2003-12-05
  186. -- Noèl Köthe <noel@debian.org> Sat, 6 Dec 2003 13:10:00 +0100
  187. tcpreplay (1.4.5-1) unstable; urgency=low
  188. * new upstream from 2003-08-30
  189. * updated Standards-Version
  190. * fixed a define because libnet author changed a bit
  191. (see #210341)
  192. (closes: Bug#208644)
  193. -- Noèl Köthe <noel@debian.org> Sun, 13 Sep 2003 12:19:00 +0200
  194. tcpreplay (1.4.4-1) unstable; urgency=low
  195. * new upstream from 2003-06-17
  196. -- Noel Koethe <noel@debian.org> Wed, 18 Jun 2003 12:44:00 +0200
  197. tcpreplay (1.4.2-1) unstable; urgency=low
  198. * new upstream from 2003-05-24
  199. * updated Standards-Version
  200. -- Noel Koethe <noel@debian.org> Wed, 28 May 2003 08:58:00 +0100
  201. tcpreplay (1.4.0-1) unstable; urgency=low
  202. * new upstream from 2003-05-07
  203. * updated Standards-Version
  204. * corrected Authors line in debian/copyright to make the
  205. package lintian clean
  206. -- Noel Koethe <noel@debian.org> Sun, 11 May 2003 13:16:00 +0100
  207. tcpreplay (1.3.2-1) unstable; urgency=low
  208. * new upstream from 2002-01-08
  209. -- Noel Koethe <noel@debian.org> Fri, 10 Jan 2003 17:31:00 +0100
  210. tcpreplay (1.3.1-2) unstable; urgency=low
  211. * buildd's could find the libnet version
  212. I set this now with a configure switch
  213. -- Noel Koethe <noel@debian.org> Tue, 31 Dec 2002 17:58:00 +0100
  214. tcpreplay (1.3.1-1) unstable; urgency=low
  215. * found current project page with latest version 1.3.1
  216. from 2002-12-23
  217. * added URL to description
  218. * made a rules file from scratch
  219. -- Noel Koethe <noel@debian.org> Tue, 31 Dec 2002 16:58:00 +0100
  220. tcpreplay (1.0.1-2) unstable; urgency=low
  221. * took package from QA
  222. (closes: Bug#123507)
  223. * closing fixed bugs
  224. (closes: Bug#156202)
  225. (closes: Bug#127627)
  226. (closes: Bug#127626)
  227. * updated Standards-Version
  228. -- Noel Koethe <noel@debian.org> Tue, 31 Dec 2002 15:58:00 +0100
  229. tcpreplay (1.0.1-1.2) unstable; urgency=low
  230. * Non maintainer upload
  231. * Rebuilt with new libpcap to remove dependency on libpcap0, which I
  232. got removed from unstable by accident. Sorry about this...
  233. -- Torsten Landschoff <torsten@debian.org> Sat, 10 Aug 2002 11:37:41 +0200
  234. tcpreplay (1.0.1-1.1) unstable; urgency=low
  235. * NMU
  236. * added old download URL and new CVS URL
  237. (http://cvs.tcpdump.org/cgi-bin/cvsweb/tcpreplay/)
  238. (closes: Bug#127627)
  239. * removed 404 URL from description
  240. (closes: Bug#127626)
  241. * corrected possition of build-depends in debian/control
  242. -- Noel Koethe <noel@debian.org> Thu, 30 Jan 2002 23:58:00 +0100
  243. tcpreplay (1.0.1-1) unstable; urgency=low
  244. * First upstream version.
  245. -- Raphael Bossek <bossekr@debian.org> Tue, 29 Aug 2000 21:36:07 +0200