configure-pcap.patch 1.3 KB

123456789101112131415161718192021222324252627282930
  1. --- tcpreplay-3.4.4/configure.ac.orig 2010-04-05 02:58:05.000000000 +0200
  2. +++ tcpreplay-3.4.4/configure.ac 2012-07-06 23:27:29.000000000 +0200
  3. @@ -39,6 +39,7 @@
  4. AC_SUBST(host)
  5. AC_SUBST(build)
  6. AC_SUBST(target)
  7. +MULTIARCH=$(dpkg-architecture -qDEB_HOST_MULTIARCH)
  8. have_cygwin=no
  9. AC_MSG_CHECKING([for cygwin development environment])
  10. @@ -355,6 +356,8 @@
  11. LPCAPLIB="-L${testdir}/lib64 -lpcap"
  12. elif test -f "${testdir}/lib/libpcap${shrext_cmds}" ; then
  13. LPCAPLIB="-L${testdir}/lib -lpcap"
  14. + elif test -f "${testdir}/lib/$MULTIARCH/libpcap${shrext_cmds}" ; then
  15. + LPCAPLIB="-L${testdir}/lib/$MULTIARCH/lib -lpcap"
  16. else
  17. AC_ERROR([Unable to find libpcap in ${testdir}])
  18. fi
  19. @@ -364,6 +367,9 @@
  20. LPCAPLIB="${testdir}/lib/libpcap.${libext}"
  21. elif test -f "${testdir}/lib/libwpcap.${libext}" ; then
  22. LPCAPLIB="${testdir}/lib/libwpcap.${libext}"
  23. + elif test -f "${testdir}/lib/$MULTIARCH/libpcap.${libext}" ; then
  24. + LPCAPLIB="${testdir}/lib/$MULTIARCH/libpcap.${libext}"
  25. +
  26. AC_DEFINE([HAVE_WINPCAP], [1], [Do we have WinPcap?])
  27. else
  28. AC_ERROR([Unable to find matching library for header file in ${testdir}])