1234567891011121314151617181920212223242526272829303132333435363738394041424344454647 |
- #!/usr/bin/make -f
- PACKAGE=u3-tool
- VERSION=$(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)-.*/\1/p')
- TARBALL=$(PACKAGE)_$(VERSION).orig.tar.gz
- SVN_ROOT=http://u3-tool.svn.sourceforge.net/svnroot/u3-tool/trunk/
- SVN_REV=$(shell echo $(VERSION) | sed 's/.*svn//' )
- build: build-stamp
- build-stamp:
- dh build --before build
- $(MAKE) -C src
- dh build --after build
- touch $@
- clean:
- dh clean
- $(MAKE) -C src clean
- install: build
- dh install --before dh_installman
- install -D -m 0644 $(CURDIR)/doc/u3-tool.1 \
- $(CURDIR)/debian/u3-tool/usr/share/man/man1/u3_tool.1
- dh install --remaining
- binary-indep: install
- dh binary-indep
- binary-arch: install
- dh binary-arch
- binary: binary-indep binary-arch
- dh binary
- get-orig-source:
- @echo "Fetching $(PACKAGE) from $(SVN_ROOT) at revision $(SVN_REV)."
- rm -rf get-orig-source $(TARBALL)
- mkdir get-orig-source
- svn co $(SVN_ROOT) get-orig-source/upstream
- svn export -r $(SVN_REV) get-orig-source/upstream \
- get-orig-source/$(PACKAGE)-$(VERSION).orig
- GZIP=--best tar czf $(TARBALL) -C get-orig-source $(PACKAGE)-$(VERSION).orig
- rm -rf get-orig-source
- @echo "Generated $(TARBALL)."
- .PHONY: build clean binary-indep binary-arch binary install get-orig-source
|