rules 657 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. #!/usr/bin/make -f
  2. # Copyright 2005, 2006, 2007 David Martínez Moreno.
  3. # Under GPL v2.
  4. # Uncomment this to turn on verbose mode.
  5. # export DH_VERBOSE=1
  6. build: build-stamp
  7. build-stamp:
  8. $(MAKE)
  9. touch build-stamp
  10. install: build
  11. dh_testdir
  12. dh_testroot
  13. dh_clean -k
  14. dh_installdirs
  15. dh_install
  16. dh_installdocs
  17. dh_installman
  18. dh_installchangelogs NEWS
  19. dh_link
  20. binary-arch: build install
  21. dh_testdir
  22. dh_testroot
  23. dh_strip
  24. dh_compress
  25. dh_fixperms
  26. dh_installdeb
  27. dh_shlibdeps
  28. dh_gencontrol
  29. dh_md5sums
  30. dh_builddeb
  31. binary-indep:
  32. # do nothing
  33. binary: binary-arch binary-indep
  34. clean:
  35. dh_testdir
  36. dh_testroot
  37. $(MAKE) clean
  38. rm -f *-stamp
  39. dh_clean