rules 832 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. #!/usr/bin/make -f
  2. # Copyright 2005, 2006, 2007 David Martínez Moreno.
  3. # Under GPL v2.
  4. # Uncomment this to turn on verbose mode.
  5. # export DH_VERBOSE=1
  6. DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
  7. ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
  8. PLATFORM=freebsd
  9. else
  10. PLATFORM=linux
  11. endif
  12. build: build-stamp
  13. build-stamp:
  14. $(MAKE) PLATFORM=$(PLATFORM)
  15. touch build-stamp
  16. install: build
  17. dh_testdir
  18. dh_testroot
  19. dh_clean -k
  20. dh_installdirs
  21. dh_install
  22. dh_installdocs
  23. dh_installman
  24. dh_installchangelogs NEWS
  25. dh_link
  26. binary-arch: build install
  27. dh_testdir
  28. dh_testroot
  29. dh_strip
  30. dh_compress
  31. dh_fixperms
  32. dh_installdeb
  33. dh_shlibdeps
  34. dh_gencontrol
  35. dh_md5sums
  36. dh_builddeb
  37. binary-indep:
  38. # do nothing
  39. binary: binary-arch binary-indep
  40. clean:
  41. dh_testdir
  42. dh_testroot
  43. $(MAKE) clean
  44. rm -f *-stamp
  45. dh_clean