1234567891011121314151617181920212223 |
- Subject: Used for avoiding calling vbladed without arguments,
- and while at it, add the usage command line.
- Author: David Martínez Moreno <ender@debian.org>
- Date: 2005-10-28
- Last-Update: 2007-04-08
- --- a/vbladed
- +++ b/vbladed
- @@ -3,4 +3,14 @@
- # output is directed to syslogd
- #
-
- +# Although logging goes to syslog, let's going to
- +# protect ourselves against the most common way or
- +# calling vbladed: without arguments. While at it, we guard
- +# ourselves against wrong number of parameters.
- +if [ $# -lt 4 ]
- +then
- + echo "usage: ./vblade <shelf> <slot> <ethn> <device>" >&2
- + exit 1
- +fi
- +
- sh -c "`dirname $0`/vblade $* < /dev/null 2>&1 | logger -t vbladed" &
|