rules 589 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. # export DH_VERBOSE=1
  4. build: build-stamp
  5. build-stamp:
  6. $(MAKE)
  7. touch build-stamp
  8. install: build
  9. dh_testdir
  10. dh_testroot
  11. dh_clean -k
  12. dh_installdirs
  13. dh_install
  14. dh_installdocs
  15. dh_installman
  16. dh_installchangelogs NEWS
  17. dh_link
  18. binary-arch: build install
  19. dh_testdir
  20. dh_testroot
  21. dh_strip
  22. dh_compress
  23. dh_fixperms
  24. dh_installdeb
  25. dh_shlibdeps
  26. dh_gencontrol
  27. dh_md5sums
  28. dh_builddeb
  29. binary-indep:
  30. # do nothing
  31. binary: binary-arch binary-indep
  32. clean:
  33. dh_testdir
  34. dh_testroot
  35. $(MAKE) clean
  36. rm -f *-stamp
  37. dh_clean