rules 563 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. # export DH_VERBOSE=1
  4. build: build-stamp
  5. build-stamp:
  6. $(MAKE)
  7. touch build-stamp
  8. binary-arch: build
  9. dh_testdir
  10. dh_testroot
  11. dh_clean -k
  12. dh_installdirs
  13. dh_install
  14. dh_installdocs
  15. dh_installman debian/vblade.8 debian/vbladed.8
  16. dh_installchangelogs NEWS
  17. dh_strip
  18. dh_compress
  19. dh_fixperms
  20. dh_installdeb
  21. dh_shlibdeps
  22. dh_gencontrol
  23. dh_md5sums
  24. dh_builddeb
  25. binary-indep:
  26. # do nothing
  27. binary: binary-arch binary-indep
  28. clean:
  29. dh_testdir
  30. dh_testroot
  31. $(MAKE) clean
  32. rm -f *-stamp
  33. dh_clean