rules 866 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. #!/usr/bin/make -f
  2. # Copyright 2005, 2006, 2007 David Martínez Moreno.
  3. # Under GPL v2.
  4. # Uncomment this to turn on verbose mode.
  5. # export DH_VERBOSE=1
  6. DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
  7. ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
  8. PLATFORM=freebsd
  9. else
  10. PLATFORM=linux
  11. endif
  12. build: build-stamp
  13. build-stamp:
  14. dh_quilt_patch
  15. $(MAKE) PLATFORM=$(PLATFORM)
  16. touch build-stamp
  17. install: build
  18. dh_testdir
  19. dh_testroot
  20. dh_clean -k
  21. dh_installdirs
  22. dh_install
  23. dh_installdocs
  24. dh_installman
  25. dh_installchangelogs NEWS
  26. dh_link
  27. binary-arch: build install
  28. dh_testdir
  29. dh_testroot
  30. dh_strip
  31. dh_compress
  32. dh_fixperms
  33. dh_installdeb
  34. dh_shlibdeps
  35. dh_gencontrol
  36. dh_md5sums
  37. dh_builddeb
  38. binary-indep:
  39. # do nothing
  40. binary: binary-arch binary-indep
  41. clean:
  42. dh_testdir
  43. dh_testroot
  44. $(MAKE) clean
  45. rm -f *-stamp
  46. dh_quilt_unpatch
  47. dh_clean