rules 442 B

1234567891011121314151617181920212223
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. # export DH_VERBOSE=1
  4. DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
  5. ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
  6. PLATFORM=freebsd
  7. else
  8. PLATFORM=linux
  9. endif
  10. %:
  11. dh $@ --parallel
  12. override_dh_auto_build:
  13. $(MAKE) PLATFORM=$(PLATFORM)
  14. override_dh_auto_install:
  15. $(MAKE) install prefix=debian/vblade/usr
  16. override_dh_installchangelogs:
  17. dh_installchangelogs NEWS