upstream.typos.patch 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. Description: Typo fixes
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2020-12-20
  4. Bug: https://github.com/Yepkit/ykush/issues/31
  5. --- a/src/help/ykush_help.cpp
  6. +++ b/src/help/ykush_help.cpp
  7. @@ -45,7 +45,7 @@
  8. std::cout << " ykush3\t\tYKUSH3 board.\n";
  9. std::cout << " ykushxs\tYKUSHXS board.\n";
  10. std::cout << "The [board_name] must be provided for commands addressed for a specific board.\n";
  11. - std::cout << "For general or common commands, applicable to all board models, the [board_name] is to ommited from the command.\n";
  12. + std::cout << "For general or common commands, applicable to all board models, the [board_name] has to be omitted from the command.\n";
  13. }
  14. void Help::print_common_options(void)
  15. @@ -64,7 +64,7 @@
  16. std::cout << "-u 1|2|3|a Power Up/On downstream port number downstream_number\n";
  17. - std::cout << "-s serial_number Board serial number to wich the command is addressed.\n";
  18. + std::cout << "-s serial_number Board serial number to which the command is addressed.\n";
  19. std::cout << " When multiple YKUSH boards are connected to a host, this option should be used\n";
  20. std::cout << " to specify the board. If more than one board is connected and this option is not\n";
  21. std::cout << " provided the command will be sent to the first board in the USB enumeration list.\n";
  22. @@ -90,7 +90,7 @@
  23. std::cout << "-u 1|2|3|a Power Up/On downstream port number downstream_number\n";
  24. - std::cout << "-s serial_number Board serial number to wich the command is addressed.\n";
  25. + std::cout << "-s serial_number Board serial number to which the command is addressed.\n";
  26. std::cout << " When multiple YKUSH boards are connected to a host, this option should be used\n";
  27. std::cout << " to specify the board. If more than one board is connected and this option is not\n";
  28. std::cout << " provided the command will be sent to the first board in the USB enumeration list.\n";
  29. @@ -131,7 +131,7 @@
  30. std::cout << "-u Power Up/On the downstream port\n";
  31. - std::cout << "-s serial_number Board serial number to wich the command is addressed.\n";
  32. + std::cout << "-s serial_number Board serial number to which the command is addressed.\n";
  33. std::cout << " When multiple YKUSHXS boards are connected to a host, this option should be used\n";
  34. std::cout << " to specify the board. If more than one board is connected and this option is not\n";
  35. std::cout << " provided the command will be sent to the first board in the USB enumeration list.\n";