209-magic-update-os2.dpatch 907 B

1234567891011121314151617181920212223
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 209-magic-update-os2.dpatch
  3. ##
  4. ## DP: Update OS/2 REXX magic.
  5. @DPATCH@
  6. diff -Naurp file.orig/magic/Magdir/msdos file/magic/Magdir/msdos
  7. --- file.orig/magic/Magdir/msdos 2008-06-13 09:44:56.000000000 +0200
  8. +++ file/magic/Magdir/msdos 2008-06-13 09:51:35.000000000 +0200
  9. @@ -14,8 +14,10 @@
  10. # OS/2 batch files are REXX. the second regex is a bit generic, oh well
  11. # the matched commands seem to be common in REXX and uncommon elsewhere
  12. -100 regex/c =^[\ \t]{0,10}call[\ \t]{1,10}rxfunc OS/2 REXX batch file text
  13. -100 regex/c =^[\ \t]{0,10}say\ ['"] OS/2 REXX batch file text
  14. +100 search/0xffff rxfuncadd
  15. +>100 regex/c =^[\ \t]{0,10}call[\ \t]{1,10}rxfunc OS/2 REXX batch file text
  16. +100 search/0xffff say
  17. +>100 regex/c =^[\ \t]{0,10}say\ ['"] OS/2 REXX batch file text
  18. 0 leshort 0x14c MS Windows COFF Intel 80386 object file
  19. #>4 ledate x stamp %s