rules 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. #!/usr/bin/make -f
  2. export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
  3. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  4. export CFLAGS += -DBIRTHDATE=$(SOURCE_DATE_EPOCH)
  5. %:
  6. dh $@
  7. # disable dh_autoreconf since upstream's configure.ac uses the
  8. # de-ANSI-fication which was removed in autoconf a while ago.
  9. # See also https://github.com/ngircd/ngircd/issues/261
  10. override_dh_autoreconf:
  11. override_dh_auto_configure:
  12. dh_auto_configure -- \
  13. --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
  14. --prefix=/usr \
  15. --mandir=\$${prefix}/share/man \
  16. --infodir=\$${prefix}/share/info \
  17. --sysconfdir=/etc/ngircd \
  18. --with-gnutls \
  19. --with-ident \
  20. --with-pam \
  21. --enable-ipv6
  22. override_dh_auto_install:
  23. dh_auto_install
  24. # install config and sample motd file
  25. install -m 640 -D $(CURDIR)/debian/ngircd.conf \
  26. $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.conf
  27. install -m 640 -D $(CURDIR)/debian/ngircd.motd \
  28. $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.motd
  29. # make lintian happy
  30. rm $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/COPYING
  31. mv $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/ChangeLog \
  32. $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/changelog
  33. # Commands.txt is read by the daemon
  34. override_dh_compress:
  35. dh_compress -XCommands.txt