cherry-pick.v6-5-g7d2035b.correct-dependency-order-of-systemd-unit-files.patch 788 B

123456789101112131415161718192021222324252627282930313233
  1. Subject: Correct dependency order of systemd unit files
  2. Origin: v6-5-g7d2035b
  3. Upstream-Author: Nathaniel McCallum <npmccallum@redhat.com>
  4. Date: Thu Jul 12 12:09:00 2018 +0200
  5. The socket shouldn't open until all the other units have completed.
  6. Fixes: #22
  7. --- a/units/tangd.socket.in
  8. +++ b/units/tangd.socket.in
  9. @@ -1,7 +1,10 @@
  10. [Unit]
  11. Description=Tang Server socket
  12. -Requires=tangd-update.path
  13. Requires=tangd-keygen.service
  14. +Requires=tangd-update.service
  15. +Requires=tangd-update.path
  16. +After=tangd-keygen.service
  17. +After=tangd-update.service
  18. [Socket]
  19. ListenStream=80
  20. --- a/units/tangd@.service.in
  21. +++ b/units/tangd@.service.in
  22. @@ -1,7 +1,5 @@
  23. [Unit]
  24. Description=Tang Server
  25. -Requires=tangd-update.path
  26. -Requires=tangd-keygen.service
  27. [Service]
  28. StandardInput=socket